Set Output folder, keep file name

Hi there,

is it possible to only set an output folder for a transform? I need to change the date of a file but need to keep the original file name. At the moment, it is quite a bit of a hazzle and error prone (at least for me) to do this by hand, especially as the file requester (on Mac) does not allow to paste a file name.

Thanks, best

It isn’t possible to specify that an output file has the same name as an input file, because an output file might be derived from multiple input files (e.g. using a join or stack).

However to avoid issues misspelling the file name you could.

  • Click the ‘…’ browse button for the input File field.
  • Copy and paste the file name from the input File field.
  • Paste the input file name into the output File field (leaving the rest of the path).

Alternatively you can use the Batch processing feature, which does allow you to specify an output file name based on an input file name:

I see. I was hoping for some way to use the alias of an input source to derive the output name from.

The Copy and Paste (the paste part) does not work on Mac. Instead, it just bings.

Aha, Batch Processing offers exactly what I was looking for, thanks for the hint. I was not looking in that direction. It is an rather easy change of configuration. As I am processing one file per month with this transform, I was not thinking of batch-processing :wink:

Thanks, best


1 Like

I guess we could allow the use of an input file name in the main GUI in the same way we do batch processing. I will have a think about it.

Your other option is to use the command line interface and write a script that extracts the input file name and applies it to the output.

Windows: Reference > Command line arguments
Mac: Reference > Command line arguments

You can now use file name variable for output files in the latest smapshot. Please see:

1 Like

Very cool! Works like wished for!
Only issue I had, I could not enter the curly brackets {} in the output filename box. Copy-Pasted them instead. Will check on another Mac next week, if this is me or my PowerBook

This reminds that I I can not input [] on macOS in the fields for search and replace.
Do not know if it is related ?
I can input {} in search and replace.

I am able to type {} brackets in the output right pane File field on my macOS 12 iMac. I will check on a different Mac.

Do you mean in the Replace transform? Or somewhere else?

Yes it is in the Replace transform.
Here is a video:

@jimmyhartington That’s odd. I have no issue here on macOS 12.2:


What version of macOS is this on?

I am on 12.3.1. I tried to see if it was a font issue like the space issue from earlier. But changing the UI font did not allow my to input the characters.

I also tried on a Mac Air running macOS 12.1 and had no problem typing {} or [] brackets.

Strange. I will look at the code and see if I can get any ideas.

1 Like

I’ve now tried this on macOS 10.14, 12.1, 12.2 and 12.3 on 3 different Macs and haven’t had any issue typing {} or [] characters in the File field. What other software do you have running in the background? Could that be intercepting key presses before it reaches Easy Data Transform?

I think this probably has to do with international keyboard layouts, German in my case. It usually always relates to that, that‘s why I usually try copy and paste first😅

1 Like

I also use Keyboard Maestro, which could intercept the keys.
But I have tried to quit it, but it was still the same.

I have also tried to change language and locale to UK English. But it was still the same.
So it is a bit weird. I will still just copy paste the characters in.

But it is only Easy Data Transform that is showing this behaviour? And only in the Replace text edit field?

I have tested on more fields and it is the same.
Which framework is it you use for the crossplatform aspect of EDT?

Maybe I could test another app which uses the same framework.

Easy Data Transform is built on top of the Qt framework. It is used by a lot of applications. We are currently using Qt 5.15.2 on macOS.

I just tried with your other 2 apps (HyperPlan and PerfectTablePlan). I imagine they are built with the same framework. And there it seems I can input [] everywhere.