Strange Date conversion bug

Hello, amazing app!

Here’s a bug that is driving me crazy.
Input file is plain utf-8 text

just the marked date fails:

the source data is:

03-09-2022 0:00:00
04-09-2022 0:00:00
05-09-2022 0:00:00
06-09-2022 0:00:00
07-09-2022 0:00:00
08-09-2022 0:00:00

Transformation is:

<parameter type="7" name="Input" value="dd-MM-yyyy%20H%3Amm%3Ass"/>
<parameter type="7" name="Output" value="dd-MM-yyyy"/>


I tried to reproduce the problem here, but couldm’t. Perhaps there is a spurious whitespace in that one row? Try pressing the eyeball icon to see any whitespace.


If that isn’t the problem, please send us your .transform file and input data.

Thanks for sending the data. I am not able to reproduce the problem on v1.39.1 on Mac.

I will try later on Windows.


Click on the Warnings Tab, it will show you the reason

It will display something like this

1 value does not match ‘Format from’:
‘04-09-2022 0:00:00’ at column ‘FechaNegocio’ row 3

Make sure the date in Quotes has only 1 space between 2022 and 0:00:00. The only way it is not matching if you have 2 spaces between 2022 and 0:00:00. or some other character that is not printable but giving the illusion of space.

Because format dd-MM-yyyy(1space)H:mm:ss that you specified will not match if there is more than 1 space or any other character beside space between yyyy(and)H:mm:ss

1 Like

Can’t reproduce the problem on Windows or Mac with the .csv and .transform you sent.

Perhaps a rogue character got removed in transit?

As @Anonymous says, check the warning message (I missed that).

Hi guys, the waring says:

1 value does not match 'Format from':
'04-09-2022 0:00:00' at column 'FechaNegocio' row 3

The source file, is byte-perfect.
It’s the same that I attached. Also, I checked it in hex editor… has no funny chars in between.

Theory: Might be something with OS regional settings?

[HKEY_CURRENT_USER\Control Panel\International]
"s1159"="a. m."
"s2359"="p. m."
"sLongDate"="d 'de' MMMM 'de' yyyy"
"sYearMonth"="MMMM 'de' yyyy"

Easy Data Transform uses it’s own locale (set in Preferences) and that shouldn’t affect dd-MM-yyyy or dd-MM-yyyy H:mm:ss. Is it possible that one of the characters is a different unicode character to what you think it is?

You could try and substitute the characters, 1 at a time, to find out if there is a rogue character.

Ok, this is what i’ve come so far:

a) debug file is written in a notepad, by hand, by me


b) Tested with only “dd-MM-yyyy”
worked perfectly

c) Added “{space}0:00:00” to same data
It appears 1 error:

(see next file)

warning is:

1 value does not match 'Format from':
'03-09-2023 0:00:00' at column 'SomeDate' row 3

format from is:
dd-MM-yyyy h:mm:ss

I just noticed that the offending file of the previous example (04-09-2023 0:00:00) now works well

Just keeps looking for me that something overloads in some variable inside EDT?

The forum don’t allow me to upload (new user), so I sent the 2 new files via email.

Thanks guys!


If it is no trouble, can you please select the original column FechaNegocio in your transform in the right side pane in EDT and copy it.


Then open new instant of EDT by clicking on File->New Window


and in this new instance of EDT click on From Clipboard


Then save the transform and upload it to as you cannot upload files in here. So that I or anyone else interested in solving this can have access to it.


One more things, can you please also tell, which version of EDT are you using? and if you apply the DateTime Format in the new From Clipboard transform, does it still have the same issue at your end.

So that when we get your new From Clipboard transform file and load it in EDT at our end and face no issues, then it will mean something wrong at your end only.

of course:

a) version: v1.39.1

b) problem persist doing it from clipboard? :arrow_right: yes

c) link to the files (after pasting from clipboard):

d) idea: is there anywhere to get a log of what causes EDT to make that warning?

e) PLEASE REMEMBER: this bug only happens when the date has the “0:00:00” suffix on them

just to narrow, i changed the “-” for “/”, problem persisted

ok, this is becoming poltergeist… i create 365 files (a whole year) and only this one row fails

1 value does not match 'Format from':
'03-09-2023 0:00:00' at column 'Date_dmy' row 246

I tried the file you emailed me with v1.39.1 on my Mac and it works as expected.

So this is very odd.

The .transform you uploaded also works as expected on my Mac.

I just noticed that the offending file of the previous example (04-09-2023 0:00:00) now works well

That makes me think it is something strange happening on your computer. What sort of anti-virus/security software do you have on your computer?

What do you see if you look at the Characters tab of the clipboard (not the transform)? I see this:

exactly the same as you:

To narrow things down, i’ve installed v1.39.1 on a second PC, and problem remains…

1 value does not match 'Format from':
'03-09-2023 0:00:00' at column 'Date_dmy' row 246

Will try to change OS regional settings and try again…


I loaded your transform file and it worked without any issues.

I missed this earlier in your reply, so it seems it is not a fix repeatable issue, it is kinda random, do you remember doing anything, after which the issue disappeared. Like saved the transform and closed the EDT and re-ran it? or closed everything up and loaded things later, like shutdown the machine and later when you opened up the transform it worked?

And are you using Windows or Mac? because in Windows, if you restart, things which were not working before, starts to work, that is why you will find on internet most of the solutions to problems in Windows, do you have latest updates, did you restart your machine? and it has become a joke that, if something not working in Windows, simply restart your machine and the problem disappears.