OneDrive Save Issues

Has anyone experienced not being able to save the transform project to a OneDrive folder? I could do an initial ‘Save as’ to a OneDrive folder, but any subsequent saves after that produces this error msg:

“Unable to save ‘C:\Users\bowee\OneDrive - ClearTone Consulting, LLC\Clients\Prison Fellowship\Software Inventory\InTune Software Inventory.transform’. Can’t open file ‘C:\Users\bowee\OneDrive - ClearTone Consulting, LLC\Clients\Prison Fellowship\Software Inventory\InTune Software Inventory.transform’ to write.”

Any help will be appreciated as I save all my work in OneDrive.

OneDrive should behave like any other folder.

Are you sure you don’t have the same .transform file open in a second Easy Data Transform instance?

I do not. I can close the app completely so it does not appear in my task bar, doubleclick the .tranform file to open the app, make a change, hit save, and then I get the message.

If I save it to local C: drive, it works fine.

I can’t reproduce that here, so far.

Which version of Windows are you on?

Make sure to check in Task Manager that you don’t have a ‘zombie’ Easy Data Transform process that has locked the file.

Does it make any difference if you re-start the computer?

Are you running anti-virus or other security software? This can sometimes cause strange issues.

Can anyone else reproduce this?

No zombie processes. I will reboot but need to do it later today since I have meetings. I will reply with outcome. (darn MSFT!!!)

It might be worth trying the suggestions here:

But strictly at your own risk!

Rebooting did not address the problem. I can recreate it with Dropbox as well. Any folder on C:drive works fine, but any of these shareable folders do not work.

That is quite strange and we haven’t had any other reports of this. So I wonder this issue isn’t on your computer, rather than in Easy Data Transform.

Are other programs able to write to these folders without any problems?

What anti-virus / security software do you have installed?

I can save repeatedly to OneDrive or DropBox folders on both Windows machines I tried it on.

Is it possible that OneDrive has locked the file so that it can sync it? What happens if you wait 60 seconds bewteen saves?

It is truly odd and if no one else is experiencing it, then clearly it must be something with my Win 11 setup, but whatever that is is not clear at all. I routinely save to both OneDrive and Dropbox from all other applications without issue.
To answer your question, using MS Defender as AV.
I’ve also set the OneDrive sync options to be “always present on device” but to no avail.
In addition to not being able to save the current project, it also does not allow me to “Save As” to the OneDrive folders - only local C drive.
I greatly appreciate your responsiveness and dialog on the matter, but certainly understand if you can’t reproduce it, then you can’t address it. I’d say there is an issue that is a combination of EDT along with some configuration aspect of my OS in regard to these shared folders.

1 Like

Hello. This inability to save to OneDrive or Dropbox has become a serious issue for me. I created a zoom video demonstrating the issue in case this could help identify the issue. you can find the video here.

Passcode: x6Q?P$.3

Hi Brian

Thanks for doing the video.

It looks from the video that the folder containing the .transform file is set to read-only:

So that is likely to explain why you can’t save it. Could the folders/file you are trying to output to be set to read-only as well? Might be worth checking the properties of the files and the folder they are in. Perhaps try creating a new file in Notepad and writing to the same folder.

Thanks for your reply. My understanding of that setting is that it’s controlled by OneDrive. That checkbox appears to be a 3-way state (blue checkbox, blue minus, clear). When I set them to clear, they all change back to blue minus, which is why I believe OneDrive controls it. Interestingly, all the files do not have Read Only checked…only the folders.

As a reminder, I can open, create, edit, save, etc any other type of file in these folders. I’ve also tried ensuring that “keep local” is checked on all files (that’s the green circle under Status) and that does not make a difference either.

So you can open the .transform file Notepad, make a trivial change (e.g. add a space) and save it?

Sorry, forgot that. Yes, can open in Notepad and save without issue.

If the folder containing a file is set to read-only, then presumably you shouldn’t be able to write to the file.

Given that:

  • it is happening to both OneDrive and DropBox (2 separate systems)
  • we can’t reproduce it
  • there are no other reports of this, so far

Then it seems to be likely to be an issue with your computer setup. Sometimes weird things like this are due to anti-virus/security software. I tried Googling the issue, but didn’t come up anything new. Hopefully we will get to the bottom of it eventually, but I am at a loss what to suggest right now.

Might be worth trying to see if another process is locking the .transform or other files. See the answer starting " You can use the Resource Monitor" at:

You can also use a File Juggler, to copy the the file to a folder you have access to , use EDT to work on it , and then move it (overwriting) to OneDrive

1 Like