Anyone experiencing hangs on Mac?

We have had a few reports now that the Mac version of Easy Data Transform sometimes hangs for a while on macOS. The typical behaviour seems to be that Easy Data Transform sometimes shows a spinning cursor and 100% CPU when focus is given back to it, even though it isn’t apparently doing any processing. If left for a while it becomes responsive again.

We suspect this may be some sort of strange interaction with macOS or configuration issue, rather than a bug in our code.

We haven’t been able to replicate this behaviour here yet, which makes it hard to debug. If you observe behaviour like this, please let us know.:

  • the version of Easy Data Transform
  • the version of macOS
  • any changes made to your Mac or installed software just before the behaviour first started
  • if you observe any sort of pattern to when the hangs occur

Hopefully we can get to the bottom of this soon.

I’m not having any problems. I’m running macOS Ventura Version 13.0 Beta (22A5311f).

1 Like

I have two Macs. The iMac I9 with 64 GB RAM works perfect but my newer Mac Book Pro M1 Max with 32 GB RAM has the problem. Both Macs are on Mac OS Monterey 12.5. The Mac Book Pro hangs up especially when Desktop Parallels is running Windows 11 (But I only run EDT on the Mac side - not on Windows). On Transforms that load on my iMac in say 5 seconds, the same Transform will spin the beach ball up to a minute on my MacBook Pro. Also the beach ball will show up while using and adjusting the Transforms basically making it unusable. This is not a major problem for me right now because I work from home and have both Computers. If I can help in any other way, please let me know.

I am looking into producing a version with logging will hopefully allow to find out what macOS is up to.

Here is a snapshot release for Mac with event logging:

If (and only if) you are suffering from this hanging issue, please:

  • install the release linked above
  • use as usual
  • when the hang occurs:
    • wait until the hang clears (or 5 minutes, whichever comes first)
    • exit Easy Data Transform (kill the process if you can’t)
    • email us the the edt_log.txt file in your home folder (e.g. /Users/username/edt_log.txt), ideally together with the .transform and input files

This release will be slower, due to the event logging. We don’t recommend it for general use.

Setting some of the controls to appear red seems to be causing the repaint to loop continuously in some circumstances on the Mac. You can hopefully work around it for now by checking ‘show advanced’ in the Left pane so it isn’t red.


Thanks to Mark B for his patience helping to track this down. A proper fix will hopefully be out soon.

I believe this snapshot release fixes the problem. If you have been affected by this issue, please try it and let us know:

Sorry for the delay, I was very busy today. I just tried the snapshot release and it worked great - no issues.

Thanks for letting me know.

Fix is now at: